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Limited Warranty, Limitations Of Liability And Restrictions 
Geophysical Survey Systems, Inc. hereinafter referred to as GSSI, warrants that for a period of  
24 months from the delivery date to the original purchaser this product will be free from defects in 
materials and workmanship. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, GSSI 
DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. GSSI's obligation is limited to 
repairing or replacing parts or equipment which are returned to GSSI, transportation and insurance pre-
paid, without alteration or further damage, and which in GSSI's judgment, were defective or became 
defective during normal use. 

GSSI ASSUMES NO LIABILITY FOR ANY DIRECT, INDIRECT, SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES OR INJURIES CAUSED BY PROPER OR IMPROPER OPERATION 
OF ITS EQUIPMENT, WHETHER OR NOT DEFECTIVE. 

Before returning any equipment to GSSI, a Return Material Authorization (RMA) number must be 
obtained. Please call the GSSI Customer Service Manager who will assign an RMA number. Be sure to 
have the serial number of the unit available 
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GPS-Related Setup Information for 
SIR® 20 Systems Configured with an 

Acumen Data Logger and Trimble AG132 GPS 

General Setup Information 
The Trimble GPS unit sends GPS coordinates in NMEA-183 format out through Port A (on the yellow 
box) to the serial connection labeled “Data” on the Data Logger (white box).  

The Configuration Serial port connection on the Data Logger is connected via serial cable to the Serial 
Port on the ToughBook laptop of the SIR 20 system. 

Some of the settings on the Trimble GPS unit and the Data Logger may need to be adjusted from their 
default values in order for the logging to work properly with the SIR 20. These specific settings are 
described below. 

Trimble GPS 
GPS data from the Trimble GPS is logged using the Acumen Data Logger. The GPS settings are modified 
from the front panel on the yellow box. These settings are stored in the GPS memory and once set, they 
should not have to be adjusted again. We have modified the following settings from their default values 
on the Trimble GPS: 

Communication Port A: (see Trimble manual) 

• Input: None 

• Output: NMEA 

• Output Baud Rate: 9600 

• Output Message: GGA (disable all others) 

• Output Rate: ASAP 

• GPS Config: (see Trimble manual) 

• Position Rate: 5 Hz 

• DGPS Config: (see Trimble manual) 

• Source: OmniStar  

Note: OmniStar is a paid subscription service that must be renewed yearly (www.omnistar.com). 

Note: GSSI does not sell the Trimble. Please visit http://www.trimble.com or a local dealer. 

http://www.trimble.com/
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Acumen Data Logger Version (rev.) 8.9 
The setup information is provided for reference purposes in case of memory corruption. 

The settings on the Acumen Data Logger shipped with the SIR 20 system are factory preset and should 
not have to be modified. However, if you should need to change these settings, you will have to open it up 
to make changes to the configuration port. 

The SIR 20 ToughBook computer serial communication port is set to 115,200 bps. If there is a need to 
adjust the configuration port baud rate, open the enclosure and use switches S1-1, S1-2, S1-3 and S1-4 to 
select a baud rate of 115,200 bps for the configuration.  

Data Logger Internal Communication Switch Settings as used with the SIR 20: 

• S1-1=OFF 

• S1-2=ON 

• S1-3=ON 

• S1-4=ON  

After setting the switches, return the device to its enclosure. 

HyperTerminal 
Other Acumen data logger settings are adjusted using the HyperTerminal communication utility in 
Windows XP. To start HyperTerminal: 

1 Select Start > All Programs > Accessories > Communications > HyperTerminal.  

2 A window opens asking for a name and icon for the connection. Specify a name such as “Acumen 
Data Logger” and press OK. 

3 The next window that opens asks for connection information. In the drop-down box labeled Connect 
Using change the option to COM1 and press OK. 

4 The next window allows you to specify port settings. Specify the following parameters: 

• Bits per second: 115200 

• Data Bits: 8 

• Parity: None 

• Stop Bits: 1 

• Flow control: Hardware 

5 Then press OK. 

6 The HyperTerminal window should now open. Select the Save option from the file menu item. You 
will now be able to use these settings for future sessions. 
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Checking Data Logger Settings 
The steps listed below describe how to check and modify data port settings: 

1 Create a HyperTerminal session using the steps listed above or recall a saved HyperTerminal setup. 

2 Connect a serial cable between the Configuration serial port on the data logger and Serial Port 1 on 
the Panasonic ToughBook. 

3 Connect the power to the data logger. You should see the Main menu (Figure 1). If you don’t see the 
Main menu, press the Enter key. Sometimes you’ll need to do this to bring up the screen below.  

• If you see GPS data scrolling on the screen, this means the unit is in pass-through mode. To 
disable pass-through mode, press Shift-+++.  
 

 
Figure 1: Data Logger Main menu. 

4 Press 6 to view the Recording Parameters menu (Figure 2): 
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Figure 2: Recording Parameters menu. 

5 You can create the Current filename format using menu item 1, Change target file. 

6 Set menu item 2, Toggle overwrite-oldest mode, to OFF. 

7 Set menu item 3, Toggle append mode” to OFF. 

8  Set“Set Scheduled file close parameters” to OFF. 

9 Set “Time stamp incoming lines” to OFF. 

10 Set “Power up in pass-through mode” to OFF. 

11 Press Q to exit the Recording Parameters menu.  

12 From the Main menu, press 7 to view the File System Functions menu (Figure 3). Again, ensure the 
settings agree and press Q when done. Keep in mind that Current filename should conform to your 
file naming convention.  
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Figure 3: File System Functions menu. 

13 Press 9 to view the Data Port Configuration (Figure 4). Be sure the current settings are appropriate for 
the GPS you are using.  

14 Press Enter or ESC to return to the Main menu. 

• If the Current Settings in this window do not match the settings that your GPS system requires, 
you should make the appropriate changes with respect to the Data Port Configuration (baud rate) 
as well as the Handshaking settings in order to establish communications between the Acumen 
data logger and your GPS system. Note, in the previous GPS example, the Trimble AG132 was 
set to 9600. 

 
Figure 4: Data Port Configuration menu. 

15 When you are finished, select Call > Disconnect from the HyperTerminal menu. 
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Acumen Data Logger Version (rev.) 1.1.060109 
The setup information is provided for reference purposes in case of memory corruption. 

The settings on the Acumen Data Logger shipped with the SIR 20 system are factory preset and should 
not have to be modified. However, if you should need to change these settings, you will have to open it up 
to make changes to the configuration port. 

The SIR 20 ToughBook computer serial communication port is set to 115,200 bps. If there is a need to 
adjust the configuration port baud rate, open the enclosure and use switches S1-1, S1-2, S1-3 and S1-4 to 
select a baud rate of 115,200 bps for the configuration.  

Data Logger Internal Communication Switch Settings as used with the SIR 20: 

• S1-1=OFF 

• S1-2=ON 

• S1-3=ON 

• S1-4=ON  

After setting the switches, return the device to its enclosure. 

HyperTerminal 
Other Acumen data logger settings are adjusted using the HyperTerminal communication utility in 
Windows XP. To start HyperTerminal: 

1 Select Start > All Programs > Accessories > Communications > HyperTerminal.  

2 A window opens asking for a name and icon for the connection. Specify a name such as “Acumen 
Data Logger” and press OK. 

3 The next window that opens asks for connection information. In the drop-down box labeled Connect 
Using change the option to COM1 and press OK. 

4 The next window allows you to specify port settings. Specify the following parameters: 

Bits per second: 115200 

Data Bits: 8 

Parity: None 

Stop Bits: 1 

Flow control: Hardware 

5 Then press OK. 

6 The HyperTerminal window should now open. Select the Save option from the file menu item. You 
will now be able to use these settings for future sessions. 
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Checking Data Logger Settings 
The steps listed below describe how to check and modify data port settings: 

1 Create a HyperTerminal session using the steps listed above or recall a saved HyperTerminal setup. 

2 Connect a serial cable between the Configuration serial port on the data logger and Serial Port 1 on 
the Panasonic ToughBook. 

3 Connect the power to the data logger. You should see the Main menu (Figure 1). If you don’t see the 
Main menu, press the Enter key. Sometimes you’ll need to do this to bring up the screen below.  

• If you see GPS data scrolling on the screen, this means the unit is in pass-through mode. To 
disable pass-through mode, press Shift-+++.  
 

 
Figure 5: Data Logger Main menu. 

4 Press 6 to view the Recording Parameters menu (Figure 2): 
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Figure 6: Recording Parameters menu. 

5 You can create the Current filename format using menu item 1, Change target file. 

6 Set menu item 2, Toggle overwrite-oldest mode, to OFF. 

7 Set menu item 3, Toggle append mode” to OFF. 

8  Set“Set Scheduled file close parameters” to OFF. 

9 Set “Time stamp incoming lines” to OFF. 

10 Set “Power up in pass-through mode” to OFF. 

11 Set “Operate in low-power mode” to OFF 

12 Set “Flush buffer when recording starts” to ON 

13 Set “Disable indicators” to ON 

14 Press Q to exit the Recording Parameters menu.  

15 From the Main menu, press 7 to view the File System Functions menu (Figure 3). Again, ensure the 
settings agree and press Q when done. Keep in mind that Current filename should conform to your 
file naming convention.  
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Figure 7: File System Functions menu. 

16 Press 9 to view the Data Port Configuration (Figure 4). Be sure the current settings are appropriate for 
the GPS you are using.  

17 Press Enter or ESC to return to the Main menu. 

• If the Current Settings in this window do not match the settings that your GPS system requires, 
you should make the appropriate changes with respect to the Data Port Configuration (baud rate) 
as well as the Handshaking settings in order to establish communications between the Acumen 
data logger and your GPS system. Note, in the previous GPS example, the Trimble AG132 was 
set to 9600. 

 
Figure 8: Data Port Configuration menu. 
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Figure 5: Data Port Configuration menu. 

18 When you are finished, select Call > Disconnect from the HyperTerminal menu. 
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RADAN Settings 
Some settings in RADAN must be specified for proper communication between the Data Logger and the 
SIR 20. You should not have to modify these settings. They are provided for reference. To view and 
modify these settings: 

1 Start RADAN.  

2 Close all open files or projects. 

3 Select View > Customize from the RADAN menu bar. 

4 Next, from the tabs in the Customize window select SIRVEYOR. 

5 You should select the following settings in the GPS Interface portion of the window (Figure 9). 

6 Click OK. 

 
Figure 9: GPS Setup window. 
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Collecting GPS Data Synchronized With GPR Data 
Once all the hardware is connected as described in the General Setup Information section and the 
software is properly configured (it is configured properly before shipping), collecting synchronized GPS 
data consists of the following steps: 

1 Power up the SIR 20, the data logger, and the GPS unit. 

2 Press the SIR 20 Icon on the ToughBook desktop. 

3 Recall a saved project, or create a new one if desired. 

4 Select Project > Edit. 

5 Move through the windows that appear by pressing the Next button until the window appears that 
contains the Enable GPS button. Press this button. There may be a delay of several seconds before 
you see the GPS information appear in the window. Make sure you are receiving valid GPS 
information. Note: Your GPS must be receiving 4 or more satellites in order to provide a good 
solution. 

6 Run the project and start collecting a file. You should hear a beep within the first several seconds of 
collecting a file. This beep signifies that GPS information is synchronized with the GPR file. 

7 Upon closing the GPR file you will see a window pop up signifying that GPS data is being 
downloaded from the logger. This may take anywhere from several seconds to more than a minute 
depending on the length of the file. 

8 GPS data will be recorded with each successive file.  

Note: If you edit the project you will need to re-enable the GPS. Each time you open a project you must 
enable the GPS as instructed in Steps 4 and 5. 

The synchronization of files collected with GPS information is performed the first time the files are 
opened in RADAN. You will immediately see the X and Y coordinates on the status bar at the bottom of 
the RADAN window when you move your mouse cursor over the data file. Alternatively, you can view 
the GPS information in the file’s database by selecting Edit > Edit Database, then double-clicking the 
GPS table.  

The GPS information is synchronized with the GPR information using two additional files created each 
time the GPR file is created. The file with the “.tmf” extension is a binary file containing time 
synchronization information at each User Mark and Distance Mark in the GPR data. The file with the 
“.txt” extension contains ASCII NMEA-183 formatted GPS records that are output from the Trimble unit.  

Note: The GPR data is synchronized with the GPS data at each User Mark and Distance Mark. 
Consequently you must adjust the ft/mark (or miles/mark, m/mark km/mark depending on your horizontal 
units) to achieve the desired GPS-GPR synchronization level for projects utilizing a distance encoder. 
One hundred ft/mark (or 25 m/mark) should be sufficient for most purposes. 
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Troubleshooting 
If you are unable to collect GPS Data: 

Symptom 1: No GPS information recorded to file. 

1 When you open a project, make sure you press the GPS button and check to ensure that the GPS 
information appears in the GPS Data window. Note: If you are not receiving a good GPS position in 
the Enable GPS Data window when you push the “Enable GPS” button, the Enable GPS Data 
window will respond with “No Data.” 

2 If you have just edited your project in some way (such as change the scans/ft or the scan rate) you 
will need to press the Enable GPS button again. Each time a project is edited, you will need to enable 
the GPS. 

Note: Each time you open or edit a data collection project you will need to press the Enable GPS 
button. This is the most common reason for not seeing GPS information in a recorded file. 

Symptom 2: Don’t see GPS information in project dialog. 

1 Check to ensure all of the serial cables are connected and the GPS system and data logger have 
power. Check to ensure there is an appropriate Compact Flash (Fat16 file format) present and that the 
data logger can write to it.  

2 Check the lights on the data logger. You should see two of them lit up (D and Active). The Active 
light indicates that power is applied and the unit is ready. The D will flash to indicate you are 
receiving GPS data from the GPS unit. When you start collecting GPR data, the R will light to 
indicate you are recording GPS data. If you suspect you are not getting data from the GPS unit, check 
the GPS unit using HyperTerm to verify the GPS unit is sending data out. Note: Some GPS units may 
need to use a null modem cable to communicate with the Data Logger DATA port. 

3 If the D and R buttons are lit, check the communication between the data logger and the SIR 20.  

• First, close RADAN on the SIR 20.  

• Then Reboot the logger by disconnecting the power, waiting at least 3 seconds, then reconnecting 
the power.  

• Restart RADAN.  

• Load a project, select edit, and progress through the dialog pages until you reach the page with 
the Enable GPS button. Press this button. Wait up to 10 seconds to see if GPS data shows up. If it 
does not, contact Technical Support. 
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Symptom 3: Can see GPS information in project dialog, but cannot collect file 
with GPS information. 

1 This can happen when the file storage system on the GPS logger is full or if the compact flash is 
missing. Follow these steps: 

• You will need to disconnect power from the Data logger and remove the compact flash card from 
the logger 

• Place the compact flash card in a compact flash adapter and connect it to a computer to manually 
delete the GPS .txt files from the Data directory on the compact flash using Windows Explorer.  

• Remove the compact flash from the adapter and place it in the Data Logger and reconnect the 
power supply to the data logger. If the compact flash has been used in other devices, be sure to 
check that it is formatted as FAT-16. 

Symptom 4: See error message “Unable to disable NMEA stream” in RADAN. 

1 Follow steps listed for Symptom 2. 

2 If the Data Logger communication has been interrupted, the SIR 20 may not be able to turn off the 
Record function.  

• If this happens, manually push the Record button to turn off the Record function. As a normal 
order of operations; on power up, the Record function should be off. When you start collecting 
GPR data using the SIR 20’s Start button, you will see that the Data Logger’s Record function 
has been turned ON (you will see the lit Record LED). When you stop collecting GPR data, the 
SIR 20 will send a command to the Data Logger to STOP Recording and you will see the Record 
function turned OFF. After the Record light has been turned off, the SIR 20 will begin to 
download the GPS data. 

GSSI Contacts 
Service and Technical Support: 

Business Hours: Monday through Friday 8:30 am to 5:00 pm EST 

Telephone: 603-893-1109 

Fax: 603-889-3984 

Email: 

applicationSupport@geophysical.com - Use of GSSI equipment and/or software. 

softwareTechSupport@geophysical.com - Problems with installation, activation, or apparent defects in 
RADAN software. 

serviceSupport@geophysical.com - Repair of GSSI equipment. 

mailto:applicationSupport@geophysical.com
mailto:softwareTechSupport@geophysical.com
mailto:serviceSupport@geophysical.com
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